Релиз Doctrine 2.4

PHP
/
2013-09-12 14:05
Просмотры: 1074

Вышла новая версия популярной ORM библиотеки Doctrine 2.4. Начиная с этой версии Doctrine не будет доступна из PEAR, только Composer. Разработчики считают, что поддержка PEAR является очень сложной и трудоемкой, по сравнении с тем количеством людей, которые изпользуют этот канал для загрузки библиотеки.

Обратная несовместимость

- Изменен DoctrineDBALSchemaConstraint API

- Багфиксы в PersistentCollection#matching()

 - Composer служит загрузчиком по умолчанию

- Вызов событий OnFlush и PostFlush

Полный список изменений DBAL и ORM.

Установка

Установка из Composer производится добавлением такого кода в composer.json:

{ 
    "require": { 
        "doctrine/common": "2.4.*", 
        "doctrine/dbal": "2.4.*", 
        "doctrine/orm": "2.4.*" 
    } 
}

Добавить комментарий

comments powered by Disqus